• Compile Error - UPDATE

    From Ray Quinn@VERT/US99 to Digital Man on Friday, April 13, 2018 03:33:00
    Rob,

    First, I want to tell you thank you for your help.
    Second, I am now back up. I tried compiling the RELEASE and DEBUG options. I didn't have success either way. The necessary files, including jsversion.h, was NOT in the gcc.linux.release directory tree. I did, however, find it in the gcc.linux.debug directory tree. I compiled with

    make USE_DOSEMU=1 VERBOSE=1 symlinks

    and it compiled without issue. I started it systemctl start sbbs and it ran all the events and seems to be doing just fine, as you can see from the Origin line below.

    Thanks again!! Your work (and those who also contribute) is appreciated.

    ---

    If the right side of the brain controls the left side of the body,
    then only left handed people are in their right minds.

    _____
    , |[][]|
    ,__| ______| |
    ,__/__]|| ________ | D8 |
    |__!___!!`--'L_______\ |__________|() ___________
    "(_)[___]====(_)(_)=| \_(___________)_/__/=(_)===(_)~'

    73 de Ray Quinn W6RAY
    GMRS WQTX645
    Visalia, CA USA DM06ii
    When all else fails, ham radio works!
    ---
    Synchronet US 99 BBS - Visalia, CA - bbs.quinnnet.org
  • From Digital Man@VERT to Ray Quinn on Friday, April 13, 2018 18:08:00
    Re: Compile Error - UPDATE
    By: Ray Quinn to Digital Man on Thu Apr 12 2018 08:33 pm

    Rob,

    First, I want to tell you thank you for your help.
    Second, I am now back up. I tried compiling the RELEASE and DEBUG options. I didn't have success either way. The necessary files, including jsversion.h, was NOT in the gcc.linux.release directory tree. I did, however, find it in the gcc.linux.debug directory tree. I compiled with

    make USE_DOSEMU=1 VERBOSE=1 symlinks

    and it compiled without issue. I started it systemctl start sbbs and it ran all the events and seems to be doing just fine, as you can see from the Origin line below.

    Thanks again!! Your work (and those who also contribute) is appreciated.

    No problem. If you want to create a shell account on your system for me, I could ssh-in and try a release build (in a fresh/test directory) and see what the build issue is.

    digital man

    This Is Spinal Tap quote #37:
    David St. Hubbins: We are Spinal Tap from the UK - you must be the USA!
    Norco, CA WX: 68.9F, 14.0% humidity, 13 mph ENE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Ray Quinn@VERT/US99 to Digital Man on Friday, April 13, 2018 22:03:00

    If you want to create a shell account on your system for me, I
    could ssh-in and try a release build (in a fresh/test directory) and see what the build issue is.

    Sure thing. Email me w6ray at w6ray dot com with your preferred user name and password and I will set
    it up. I am curious.

    ---

    If the right side of the brain controls the left side of the body,
    then only left handed people are in their right minds.

    _____
    , |[][]|
    ,__| ______| |
    ,__/__]|| ________ | D8 |
    |__!___!!`--'L_______\ |__________|() ___________
    "(_)[___]====(_)(_)=| \_(___________)_/__/=(_)===(_)~'

    73 de Ray Quinn W6RAY
    GMRS WQTX645
    Visalia, CA USA DM06ii
    When all else fails, ham radio works!
    ---
    Synchronet US 99 BBS - Visalia, CA - bbs.quinnnet.org
  • From Digital Man@VERT to Ray Quinn on Saturday, April 14, 2018 21:07:00
    Re: Re: Compile Error - UPDATE
    By: Ray Quinn to Digital Man on Fri Apr 13 2018 03:03 pm


    If you want to create a shell account on your system for me, I
    could ssh-in and try a release build (in a fresh/test directory) and see what the build issue is.

    Sure thing. Email me w6ray at w6ray dot com with your preferred user name and password and I will set
    it up. I am curious.

    I got a failure at the same point:

    checking for NSPR - version >= 4.7.0... yes
    configure: error: system NSPR does not support PR_STATIC_ASSERT
    GNUmakefile:52: recipe for target '../build/../../src/../3rdp/gcc.linux.debug/mozjs/lib/libmozjs185-1.0.a' failed

    I think this indicates a problem with your NSPR installation.

    Here's what my (working) NSPR package install looks like:

    # apt show libnspr4-dev
    Package: libnspr4-dev
    Version: 2:4.12-6
    Priority: optional
    Section: libdevel
    Source: nspr

    I can't check yours without root perms, but I'm guessing that is where the problem lies.

    digital man

    This Is Spinal Tap quote #44:
    It really, it does disturb me, but i'll rise above it; I'm a professional. Norco, CA WX: 85.1F, 9.0% humidity, 0 mph E wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Ray Quinn@VERT/US99 to Digital Man on Sunday, April 15, 2018 02:46:00
    Re: Re: Compile Error - UPDATE

    I got a failure at the same point:

    checking for NSPR - version >= 4.7.0... yes
    configure: error: system NSPR does not support PR_STATIC_ASSERT GNUmakefile:52: recipe for target '../build/../../src/../3rdp/gcc.linux.debug/mozjs/lib/libmozjs185-1.0.a' failed

    I think this indicates a problem with your NSPR installation.

    Here's what my (working) NSPR package install looks like:

    # apt show libnspr4-dev
    Package: libnspr4-dev
    Version: 2:4.12-6
    Priority: optional
    Section: libdevel
    Source: nspr

    This is what I got:

    sbbs@bbs:~$ apt show libnspr4-dev
    Package: libnspr4-dev
    Version: 2:4.12-6
    Priority: optional
    Section: libdevel
    Source: nspr
    Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla- maintainers@lists.alioth.debian.org>
    Installed-Size: 1,163 kB
    Depends: libnspr4 (>= 2:4.12), libnspr4 (<= 2:4.12-6.1~)
    Homepage: http://www.mozilla.org/projects/nspr/
    Tag: devel::lang:c, devel::library, implemented-in::c, role::devel-lib,
    suite::netscape
    Download-Size: 229 kB
    APT-Manual-Installed: yes
    APT-Sources: http://ftp.us.debian.org/debian stretch/main i386 Packages Description: Development files for the NetScape Portable Runtime library
    This library provides platform independent non-GUI operating system
    facilities including:
    * threads,
    * thread synchronisation,
    * normal file I/O and network I/O,
    * interval timing and calendar time,
    * basic memory management (malloc and free),
    * shared library linking.
    .
    Install this package if you wish to develop your own programs using the
    NetScape Portable Runtime library.



    I can't check yours without root perms, but I'm guessing that is where the problem lies.

    You should be able to using sudo.



    ---

    If the right side of the brain controls the left side of the body,
    then only left handed people are in their right minds.

    _____
    , |[][]|
    ,__| ______| |
    ,__/__]|| ________ | D8 |
    |__!___!!`--'L_______\ |__________|() ___________
    "(_)[___]====(_)(_)=| \_(___________)_/__/=(_)===(_)~'

    73 de Ray Quinn W6RAY
    GMRS WQTX645
    Visalia, CA USA DM06ii
    When all else fails, ham radio works!
    ---
    Synchronet US 99 BBS - Visalia, CA - bbs.quinnnet.org
  • From Digital Man@VERT to Ray Quinn on Sunday, April 15, 2018 03:52:00
    Re: Re: Compile Error - UPDATE
    By: Ray Quinn to Digital Man on Sat Apr 14 2018 07:46 pm

    Re: Re: Compile Error - UPDATE

    I got a failure at the same point:

    checking for NSPR - version >= 4.7.0... yes
    configure: error: system NSPR does not support PR_STATIC_ASSERT GNUmakefile:52: recipe for target '../build/../../src/../3rdp/gcc.linux.debug/mozjs/lib/libmozjs185-1.0.a' failed

    I think this indicates a problem with your NSPR installation.

    Here's what my (working) NSPR package install looks like:

    # apt show libnspr4-dev
    Package: libnspr4-dev
    Version: 2:4.12-6
    Priority: optional
    Section: libdevel
    Source: nspr

    This is what I got:

    sbbs@bbs:~$ apt show libnspr4-dev
    Package: libnspr4-dev
    Version: 2:4.12-6
    Priority: optional
    Section: libdevel
    Source: nspr
    Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla- maintainers@lists.alioth.debian.org>
    Installed-Size: 1,163 kB
    Depends: libnspr4 (>= 2:4.12), libnspr4 (<= 2:4.12-6.1~)
    Homepage: http://www.mozilla.org/projects/nspr/
    Tag: devel::lang:c, devel::library, implemented-in::c, role::devel-lib,
    suite::netscape
    Download-Size: 229 kB
    APT-Manual-Installed: yes
    APT-Sources: http://ftp.us.debian.org/debian stretch/main i386 Packages

    Mine looks the same except its for "amd64".

    I can't check yours without root perms, but I'm guessing that is where the problem lies.

    You should be able to using sudo.

    Mkay. Well I'm guessing there's a problem with the libnspr4-dev package installation. Perhaps remove and reinstall or repair it?

    digital man

    This Is Spinal Tap quote #8:
    Derek Smalls: Making a big thing out of it would have been a good idea.
    Norco, CA WX: 69.6F, 20.0% humidity, 5 mph ESE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Ray Quinn@VERT/US99 to Digital Man on Sunday, April 15, 2018 23:00:00
    Well I'm guessing there's a problem with the libnspr4-dev package installation. Perhaps remove and reinstall or repair it?

    I will try to figure that out. I do have a question, though. Why would make find
    it when compiling a DEBUG version, but not a RELEASE version. I understand that they use two different paths.

    ---

    If the right side of the brain controls the left side of the body,
    then only left handed people are in their right minds.

    _____
    , |[][]|
    ,__| ______| |
    ,__/__]|| ________ | D8 |
    |__!___!!`--'L_______\ |__________|() ___________
    "(_)[___]====(_)(_)=| \_(___________)_/__/=(_)===(_)~'

    73 de Ray Quinn W6RAY
    GMRS WQTX645
    Visalia, CA USA DM06ii
    When all else fails, ham radio works!
    ---
    Synchronet US 99 BBS - Visalia, CA - bbs.quinnnet.org
  • From Digital Man@VERT to Ray Quinn on Monday, April 16, 2018 10:28:00
    Re: Re: Compile Error - UPDATE
    By: Ray Quinn to Digital Man on Sun Apr 15 2018 04:00 pm

    Well I'm guessing there's a problem with the libnspr4-dev package installation. Perhaps remove and reinstall or repair it?

    I will try to figure that out. I do have a question, though. Why would make find
    it when compiling a DEBUG version, but not a RELEASE version. I understand that they use two different paths.

    When I try to build libmozjs on your system, it fails regardless of whether its DEBUG or RELEASE. In the other directory you're trying to build, you likely already had libmozjs built for debug, but not for release. So it doesn't need to run "configure" again for the DEBUG release (it's already been done). If you cleaned out that output directory (3rdp/gcc.linux.debug/mozjs) and tried a build, it would most likely fail in exactly the same manner as the release build.

    digital man

    This Is Spinal Tap quote #2:
    Nigel Tufnel: Well, this piece is called "Lick My Love Pump".
    Norco, CA WX: 52.7F, 74.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net